コンテンツに飛ぶ | ナビゲーションに飛ぶ

パーソナルツール

セクション

現在位置: ホーム / 雑記 / プログラミング / なでしこで特定のプロセスが起動・終了したらtweetするクライアントを作ってみた

なでしこで特定のプロセスが起動・終了したらtweetするクライアントを作ってみた

作者: anagot 最終変更日時 2013年09月24日 23時55分 |
カテゴリー:

PCゲームの開始・終了時などにtwitterで告知とかできるようにしてみました。

なでしこ製

本体はこんな感じ。

トークンやシークレットキーは各自取得して下さい。

##タスクトレイ常駐 母艦のタイトルは「ProcessNow!」 母艦をタスクトレイ入れる 母艦のタスクトレイクリックした時は 「終了しますか?」の二択 もし、それがはいならば、 終わる ##twitter設定 !「nakotter.nako」を取り込む ProcessNowとはNakotter そのoauthのコンシューマのトークンキー = 『秘密』 そのoauthのコンシューマのシークレット = 『秘密』 そのoauthのトークンキー = 『秘密』 そのoauthのシークレット = 『秘密』 ##設定読み込み 「監視開始」と表示 監視対象は空 コンフィグ所在=「conf.txt」 もし、(コンフィグ所在の存在=いいえ)ならば、 「コンフィグねーぞばーか」と言う 終わる 違えば、コンフィグ所在を開いて監視対象に代入 起動中は空 ##タイマーで監視を無限ループ 監視タイマーとはタイマー その間隔=60 その時満ちた時は 監視動作 監視タイマーを開始 ●監視動作 監視対象を反復 word=それ Resultは空 プロセス一覧=プロセス列挙 Result=プロセス一覧の0から「{word}」を配列検索 起動フラグ=起動中の0から「{word}」を配列検索 もし、起動フラグが"-1"ならば もし、Resultが"-1"でなければ 起動中にwordを配列追加 開始Tweet動作(word) 違えば、もし、Resultが"-1"ならば 起動中の起動フラグを配列削除 終了Tweet動作(word) ●開始Tweet動作(プロセス) ProcessNowから「{今}:{プロセス}開始なう」とつぶやく ●終了Tweet動作(プロセス) ProcessNowから「{今}:{プロセス}を終了なう」とつぶやく

 

なでしこでtwitterAPIを呼び出すために使うnakkotter.nakoはAPI1.1に対応していないため以下の通り手直し

参考URL:http://aoikujira.com/nadesiko/bugbbs/mbbs.php?m=thread&threadid=690

136,137行目
変更前
  HEADとは文字列 = 基本パラメータからヘッダ生成
  BODYとは文字列 = PARAMをURLパラメータ変換

変更後
  HEADとは文字列 = 基本パラメータからヘッダ生成
  HEADに"{\13}{\10}" & `Content-Type: application/x-www-form-urlencoded` & "{\13}{\10}"を追加 //ここ追加
  BODYとは文字列 = PARAMをURLパラメータ変換

218行目
変更前
・{文字列}APIURL{="http://api.twitter.com/1/"}

変更後
・{文字列}APIURL{="http://api.twitter.com/1.1/"}

 

conf.txtには監視するプロセスの実行ファイル名を書いておけばOK

以下のような感じで1プロセスごとに改行してください。

bf3.exe
WorldOfTanks.exe

 

実行するとタスクトレイに常駐してプロセスが開始・終了したらツイートしてくれるかと思います。

 


広告
タグ:
広告
このサイトへの言及